Tietoliikenneverkot
Luento: Reititys
|
 |
Ja taas OSI
|
 |
Malliverkko
|
 |
Terminologiaa
- AS (Autonomous System)
- Joukko verkkoja, joilla on yhteinen
reititys strategia ja joita hallinnoi yksi organisaatio
- Kaikki osat on sisäisesti kytkettyjä
eli jokaisesta AS:n osasta on polku toiseen AS:n osaan käyttäen
vain AS:n resursseja
- Alue (Area)
- AS:n sisäinen yhteinäisten
verkkojen ja pätelaitteiden muodostama joukko
|
 |
Terminologiaa
- IGP (Interior Gateway Protocol)
- Autonomisen alueen sisällä
reititystauluja ylläpidetään sisäisellä
reititysprotokollalla
Autonomisen alueen ulkopuolinen tieto saadaan ulkoisella
reititysprotokollalla, jonka informaatio siirretään
sisäiseen protokollaan
- EGP (Exterior Gateway Protocol)
- Autonomisten alueiden välillä
reititys informaatiota siirretään ulkoisella reititysprotokollalla
|
 |
Terminologiaa
- Reunareititin (Border router)
- Reititin on reunareitin, jos sillä
on vähintään yksi ulkopuolinen naapuri.
- Sisäiset naapurit (interior neighbours)
- Kaksi reititintä on sisäisiä
naapureita, jos ne ovat reunareitittimiä samassa autonomisessa
alueessa.
- Ne voivat olla epäsuorasti
kytkettyjä tai suoraan kytkettyjä toisiinsa
- Ulkoiset naapurit (exterior neighbours)
- Kaksi reititintä on ulkoisia
naapureita, jos niillä on yhteinen verkko ja ne kuuluvat
eri autonomiseen alueeseen
|
 |
Terminologiaa
- Topologinen tietokanta
- Tietokanta verkoista ja niihin liittyvistä
reitittimistä
- Alue (domain)
- Osa verkkoa, jolla on yhteneväinen
topologinen tietokanta
- Usein korvaa termin autonominen
alue
|
 |
Käsiteltävät protokollat
- sisäiset protokollat
- ulkoiset protokollat
|
 |
RIP
- Router Information Protocol
- Alunperin Xerox PARC Universal Protocol
(GWINFO)
- Käytettiin Xerox Network System
(XNS) protokolla mallissa
- Formaalisti kuvattu XNS Internet
Transport Protocol määrittelyssä (1981) sekä
RFC 1058:ssa (1988)
- Otettiin TCP/IP käyttöön
BSD UNIXin myötä vuonna 1982 ohjelmana routed
|
 |
RIP
- Perustuu hajautettuun etäisyysvektori
algoritmiin
- Käytetään sekä ajastettua
tietokannan päivitysta (joka 30s) sekä herätepohjaista
tietokannan päivitystä.
|
 |
RIP sanoman vaihto
- Jokainen reititin lähettää
reititystaulunsa muille reitittimille
- jakelulähetyksenä 255.255.255.255
- UDP-porttiin 520
- Joka 30s
- Reititystaulun muuttuessa (RND 1-5s)
|
 |
RIP sanoman vastaanottajan tilakone
- Sanoman vastaanottaja
- alustaa reititystaulunsa vastaamaan
sanoman sisältöä
- Alustaa timeout ajastimen 180s
- Mikäli reititin ei tämän
ajan kuluesa vastaanota päivitystä, oletetaan reitin
kadonneen.
- Mikäli reitti katoaa
- Asetetaan sen etäisyys äärettömään
(16) ja alustetaan garbage-collection ajastin 120s
- Jos ajastin laukeaa, poistetaan
reitti reititystaulusta
|
 |
RIP reititystaulu
- Network - verkon osoite (A, B, C -luokka)
- Next Hop - seuraavan reitittimen osoite
- Distance - etäisyys reitittimestä
kohteeseen
- Timers - ajastimet (timeout, garbage-collection)
- Flag - lippu (kuvaa tietoa siitä onko
reitti muuttunut edellisen lähetyksen jälkeen)
|
 |
RIP paketti
- Maksimissaan 512 tavua + UDP ja
IP otsikot
- Kentät:
- Command - request/response
- Version - RIP-1
- Address
- IP
- IP address , metric
|
 |
RIP
- Sallii etäisyydelle arvot 1 - 16
- 16 tarkoittaa tavoittamatonta
- Nopeuttaa silmukoiden purkautumista
- RIP ei ole tarkoitettu suurempiin
verkkoihin (vrt päivitysten kompleksisuus luennolta 4)
|
 |
RIP
- Sisältää älykkään
reitityssilmukoita poistavan mekanismin
- Yhteyden katkettua verkon A ja reitittimen
1 välillä reititin 1 mainostaa etäisyyttä
16 verkolle A
Reititin 2 ei mainosta taulukossa olevaa tietoaa
(1) sillä se on tallentanut myös tiedon, että kyseinen
etäisyys oli reitittimen
1 kautta.
- reititin 2 päivittää
tietonsa äärettömäksi
|
 |
OSPF
- Open Shortest Path First
- Avoin kaikille toteuttajille
- Hyödyntää Dijkstran
lyhimmän tien algoritmia
- Perustuu
- ARPANET reititys kokeiluihin
- OSIn IS-IS reititysprotokollaan
- Virallinen versio RFC 1247
|
 |
OSPF
- Nopea ja silmukaton uudelleen reititys
- Etäisyysvektoriprotokollat
muodostavat reitit verkossa, kun taas linkkitila protokolla tekee
sen paikallisesti
- Mahdollisuus useisiin etäisyysarvoihin
- Mahdollistaa eri tyyppisille liikenteille
erillaiset 'lyhimmät polut'
- Mahdollisuus monipolku reititykseen
- Mahdollistaa useita reittejä
samaan päätepisteeseen ja siten kuormituksen jakamisen
verkossa
- Mahdollisuus useisiin ulkoisiin reitteihin
- Osaa neutraloida silmukat sisäisesti
|
 |
OSPF
- Erotetaan käsitteet päätelaite
ja reititin
- Reititin kokoaa verkon päätelaitteet
aliverkoksi
|
 |
OSPF
- Tuki levitysverkoille
- Parien välisiä läheisyyksiä
puretaan valitsemalla pääreititin, joka toimii isäntänä
muille
- Muut solmivat läheisyyssuhteen
vain isäntään
|
 |
OSPF
- Suurten verkkojen osittaminen
- Suuret autonomiset järjestelmät
on mahdollista osittaa alueisiin
|
 |
OSPF
- Jokaisella reitittimellä topologiatietokanta
- Topologiatietokanta muodostetaan eri reitittimien
linkkitila ilmoituksista kokoamalla
|
 |
OSPF
- Uusi reititin sisältää tyhjän
topologiatietokannan
- Aluksi muodostetaan naapuruussuhde hello-protokollalla
- Tämän jälkeen linkkitilatietokannat
siirretään naapureiden välillä
- Kahden synkronoidun reitittimen
sanotaan olevan läheisiä (adjacent)
- Jokainen reitin lähettää
määrävälein linkkitilailmoituksia läheisilleen
|
 |
OSPF
- Versio: OSPF-versio
- Tyyppi: OSPF-sanomatyyppi
- Hello
- Topologiatietokannan kuvaus
- Linkkitila pyyntö
- Linkkitila päivitys (vastaus)
- Linkkitila kuittaus (edelliseen)
- Reitittimen linkki-ilmoitus
- Verkkolinkki-ilmoitus (monipääsyverkoissa)
- Linkkikoosteilmoitus
- Ulkoisten linkkien ilmoitus
- Paketin pituus
|
 |
OSPF
- Ajastin: ensimmäisestä
ilmoituksesta kulunut aika
- Optiot: Tuki TOS:lle (muut määrittelemättä)
|
 |
OSPF
- Reititin ilmoitus
- Lähetetään tieto,
jokaisen linkin tyypistä
- yksipiste
- kauttakulkuverkko
- aliverkko
- Linkin tunnus
- Ilmoittavan laitteen tunnus
- TOS-kenttä ja sitä vastaava
etäisyys
|
 |
OSPF
- Koostelinkit
- Reunareitittimet lähettävät
- Riippuen reitittimestä lähettäjä
tunnus on
- reunareittimen IP-osoite
- verkon osoite
- aliverkon osoite
- Verkkomaski lähettäjä
tunnusta vastaten
- Etäisyys määritykset
|
 |
EGP
- Exterior Gateway Protocol
- RFC 904 (1984)
- Korvasi vanhan Gateway to Gateway
protokollan, jolla ensimmäiset reitittimet kommunikoivat
keskenään
|
 |
EGP
- Perustuu 80-luvun alun periaatteeseen,
että internet
- on puumainen rakenne, jossa ei ole
silmukoita
- sisältää kaksi hierarkia
tasoa
- juuri: ARPANET + SATNET
- lehdet: Yksittäiset alueet,
jotka on liitetty yhdestä pisteestä juureen
|
 |
EGP
- Puu rakenne
- ei silmukoita
- ei silmukoita poistavia mekanismeja
- yksi reitti runkoon
- ei monta reittiä mahdollistavaa
valintaa
- Ulkoiset naapurit
- vaihtavat keskenään tietoa
mitä verkkoja niiden kautta tavoitetaan
- ensinmäinen välireititin
(first-hop) ja sen etäisyys ilmoitetaan EGP sanomassa
- etäisyys on 0-255 (255 tarkoitaa
tavoittamatonta)
|
 |
EGP
- Tilakone ja sen toiminta
- Naapurin hankinta - kaksi ulkoista
naapuria sopivat vaihtavansa EGP tietoa keskenään
- Naapurin saavutettavuus - ulkoiset
naapurit vaihtavat määrävälein (30s) sanomia
varmistaakseen linkin toiminnan
- Verkon saavutettavuus - ulkoiset
naapurit vaihtavat määrävälein (120s) tietoa
heiän kauttaan saavutettavista verkoista
|
 |
EGP
- Versio: EGP:n versio
- Sanomatyyppi:
- Naapurin hankinta
- Naapurin saavutettavuus
- Verkon saavutettavuus (poll)
- Reitityksen päivitys
- Vika
- Koodi: erottele alasanomatyypit
- Tila: erilaisia vikatilan tarkennuksia
- Tarkistussumma
- AS:n tunnus
- Järjestysnumero: kysymys/vastaus
sanomien kohdistaminen
|
 |
EGP
Säännölliset koko saavutettavuus informaation
siirrot reitittimeltä toiselle vaativat erittäin suurta
MTU:n kokoa. Käytännössä sanoma
joudutaan osittamaan useaan pakettiin, joiden katoaminen aiheuttaa
koko sanoman uudelleen lähetyksen
- Ei tarjoa minkäänlaista
suojaa väärinkäytöksiä vastaan
- Käytännössä
verkossa on aina silmukoita ja niitä tuleekin olla varmistuksien
takia
|
 |
BGP
- Border Gateway Protocol
- Virallinen määrittely RFC 1163
- Seuraavan sukupolven EGP
- Hyödyntää TCP:n palveluja
reititysinformaation siirtoon
|
 |
BGP
- Mallintaa Internetin topologiaa yleisenä
graafina (vrt OSPF)
- autonomiset järjestelmät
ovat graafin kytkentäpisteitä
- yhteydet autonomisten järjestelmien
välillä ovat graafin särmiä
- Purkaa reitityssilmukoita polkuverktorilla
- Mainostetava reitti sisältää
polkuvektorin, joka kuvaa kauttakulku alueita (AS)
- Reunareititin ei hyväksy reittiä,
mikäli sen oma alue on jo polkuvektorissa
|
 |
BGP
Autonomisen alueen sisäisten naapureiden välillä
reititys informaatio siirretään suorina yhteyksinä
EI sisäisiä reititysprotokollia
hyödyntäen
|
 |
BGP
- Markkeri: Sisältää
autentikointiin tarvitavaa tietoa, jonka vastaanottaja voi ennustaa
- Pituus: koko sanoman pituus
- Tyyppi: määrittelee sanomatyypin
- Avaus
- Päivitys
- Ilmoitus
- Ylläpito
|
 |
BGP
- Avaus
- Naapurin hankinta
- Kaksi naapuria sopii reititys informaation
vaihdosta
- TCP-porttiin 179
- Hyväksyntä ylläpitosanomalla
|
 |
BGP
- Ilmoitus
- Virheilmoituksien siirtoon käytetty
sanomatyyppi
- Sisältää
- virheilmoituksen
- virheen aiheuttaneen tietueen
|
 |
CIDR
- Classless Inter-Domain Routing
- B-luokan osoiteavaruuden rajoitukset
- B-luokan osoitteiden määrä
63555
- C-luokan verkot liian pieniä
suurelle osalle yrityksiä
- Reititysinformaation räjähdysmäinen
kasvu
- Reitittimien muisti ja prosessori
kapasiteetti ei riittänyt turvaamaan nopeuksien pysymistä
kohtuullisina
|
 |
CIDR
- C-luokan osoiteavaruus 256 osoitetta on
liian pieni suurelle osaa yrityksiä
- Tarvitaan isompia lohkoja osoitteita
- B-luokan osoiteavaruus 65535 osoitetta
on vastaavasti aivan liian iso
|
 |
CIDR
- Joulukuussa 1990 Internetissä oli 2190 reittiä
- Joulukuussa 1992 Internetissä oli 8500 reittiä
- Heinäkuussa 1995 Internetissä oli yli
29000 reittiä
|
 |
CIDR
- Ajatus on suorittaa reittien kokoamista
perustuen osoiteavaruuden kattavaan kuvaamiseen:
- verkko-osoitteella
- verkko maskilla
- Kyseinen osoiteistus mahdollistaa myös
osoiteavaruuden jakamisen 2:n potensseina
|
 |
CIDR
- Toiminta edellyttää, että
osoitteet on jaettu topologisesti mielekkäästi:
- Palvelun tarjoalla on yhtenäinen
osoiteavaruus
- Palvelun käyttäjällä
on yhtenäinen osoiteavaruus
|
 |
CIDR
- Reittien ilmoittamisen säännöt:
- Reititys kaikkii verkkoihin täytyy
tehdä pisimmän yhtäläisyyden perusteella
- Monikotiset alueet täytyy ainaa
ilmoittaa yksilöllisesti
Reitittimen, joka suorittaa reittien kokoamista,
täytyy hylätä paketit, jotka ovat kootun reitin
osia mutta eivät kuulu yhteenkään
yksilölliseen reittiin.
|
 |
CIDR
|
 |
CIDR
- Reititysprotokollat
- Alueen sisäinen
- Alueiden väliset protokollat
toimivat myös alueiden sisällä
- Käyttää protokollaa,
joka tukee kokooma informaation levitystä
- OSPF
- RIP II
- Integrated IS-IS
- E-IGRP
- Alueiden välillä
|
 |
CIDR
- CIDR-pohjaisissa verkoissa täytyy
reititystietoa vaihdettaessa huomioida
- Vaihdettavan informaation tyyppi:
- Oletus reititin
- Perinteinen verkkokohtainen informaatio
- CIDR informaatio
- Molemmissa päissä täytyy
huolehtia osoitteiden oikeasta käsittelystä (kokoaminen
ja purkaminen)
|